What's new

NRage Input Plugin V2.00 BETA (an overhaul)


The Great Gunblade Wielder
such a suggestion has already been made, and the issue is that buttons have a specicific threshold implemented for axes that works only for gamepads with square range as opposed to the 360 pads circular range.

a reduction of the threshold from 90 to 50-65 makes the sticks diagonals work on these pads but i don't want to just change it globally and then make other pads too sensitive, preferrably adding in a threshold slider would be best, but that would be a bit harder atm then just adding the threshold as a const and using one or the other based on whether a tick box is ticked in the ui.


New member
No force Feedback with nrage input by Zelda OoT or other games with my usb ff gamepad.

I am not sure, where is exactly the reason. Ok, i know PJ64 is an emulator and the plugins too. This will be never perfect.

I tried different versions now.
PJ64 v1.5, v1.6 and v2.2 with different plugins.
Jabo DInput7 Plugins only below v1.40 seems to support rumblepak
but there is a problem, so the Gamepad gives constant vibrations after starting Zelda OoT anytime. The nrage Plugin v1.82a and v2.3c or the new Version in PJ64 v2.2 gives me Feedback under the nrage plugin menu, if i am testing the rumble funktion for option "rampe" or "constant". In gameplay happens nothing.

I found out over your PJ64 FAQ Site, that jabos Plugin isn't working correctly in Version v1.6. So i am trying the plugin in different PJ64 Versions but the result is ever the same. Jabos plugin gives constant Force Feedback everytime non stop, after i set mempak to rumblepak. If i go fishing in Zelda by Hylia See, he told me "Sade, you hasn't rumblepak". But my gamepad is vibrating constantly. That's funny.

The nrage Plugin controlls the rumble function of my gamepad under testing dialog. If i press a button it rumbles on old Version 1.82a and if i press Test in new plugin Version 2.3c it gives me force Feedback too.
But nothing happens by gamepad in gameplay. On other side he told me "You are lucky, you got a rumblepak now." But only the visual rumble is shown, if i play in window mode. But this is nonsense in Fullscreen, so i hoped the controller will give me a force feedback. But it isn't so. The same result by other games like Conkers Bad Fury Day and so on.

My Gamepad is a normal older USB Gamepad (not xinput) called VRMS 2500 from Sengital / Mod-it.
Drivers correct installed. No special button on gamepad for activating rumble or controlling the force feedback.
I can only change between constant or rampe Feedback in nrage plugin. The option direct is gray. This seems only for adaptoid Controller, if i understand right.

I know, there should be a rumble, if i select a save game or by the secret places in Zelda OoT.

So what's wrong? What can i do?
Is it a problem of PJ64 or nrage plugin or the game or the ... driver?
I test the ff function of gamepad with directx FFconst.exe.
No problem. The gamepad driver seems working correct.

It is strange, that nrage can controlling my gamepad motor but nothing happens by the gameplay like example Zelda OoT.

Thanks for help.