What's new

Zelda 2 Lens of truth problem (here'e the way around it)


New member
So as many of you posted the lens of truth does not work in zeld majora's mask while running on sixtyforce. This is temporary. Once you get into the snowhead temple it generaly works and is also not neaded that much.

The following is a brief walkthrough on how to get to snowhead temple without the lens:

After you get the lens of truth simply warp back to the nearest warp point or if you don't know the song of soaring go back to the dawn of the first day.

The main reason you need the lens of truth is to get to the hot spring water so you can ultimately learn the goron lulaby. before you procede go to goron village and talk to the baby who is crying for his dad. Then go back to the ice mountain village (ithing it's called.) The hot spring is above a pond near the blacksmith's shop. Once you cross the pond you must climb the cliff using the ladders. This seems easy enough but as it turns out you can't see the ladders because the lens of truth does not work. Here's what you do:

1) Find the climbable area and start climbing. Go over to right until you fall off the ladder. This is where you want to start.
2) Climb upward (as link) 27 steps or rungs of the ladder.
3) Climb right 9 steps
4) Climb up 26 steps
5) Climb left 8 steps
6) Climb up 26 steps
7) Climb right 16 steps
8) Finaly climb upward until you reach the top.

Once you reach the top you can talk to the gorons up there and then enter the cave. Insied there is a piller sort of thing in the middle. This is blocking the spring. Stand directly in front of it and press (A) until you see the ghost of an old goron. He will give you a nice suprise. With this suprise you can move the pillar, get the spring water and unfreeze the crying goron's father who is trapped in a snowball.

I hope this is usefull to some of you. It took me quite a while to figure it all out using the "guess and check" method. Don't worry it gets easier.



New member
I've not yet had a chance to try your method (I intend to at the first chance I get), but, I have no reason to doubt it and thank you wholeheartedly. I too tried the guess and check method, but after about an hour I gave up.

Thank you kind sir.

EDIT: I have just climbed the ladder following these instructions. :D
Thanks again.
Last edited:


New member
question...which version of sixtyforce do you have ? i seem to have problems when i get the ocarina and it stops working there ..whats with that? (intel mac btw)


New member
now if we could fix the graveyard glitch... but thanks a lot this save me from hours of extreme boredom of continuously beating OoT


New member
Wow thanks. Great Job! Now i need your help again...I am in the SnowHead Temple collecting the stray fairies and ive run into a problem. Im on the 2nd Floor of the temple. im on the second story of a 2 story room with a high cieling, a real bombchu and an opened chest on the lower floor. There is a frozen eye and a freezard on the 2nd floor and a small alcove way up out of my reach...I know i need to "Put on the Lens of Truth and look for some very small invisible platforms to climb," so i can reach the top where a chest is hidden with a stray fairy inside. Did you have this same problem? Because my LoT STILL isn't working even though i am inside the temple. Can you do a guess and check here because i dont think i can do it. I tried throwing bombs& shooting arrows to help me visualize where these platforms are supposed to be, but no luck...oh! i'll check youtube...and its 2:30 in to a video called LETS PLAY MAJORAS MASK PART 19
Last edited:


New member

This was a giant help, would have been game ending I think. I was going the absolute wrong way. Thanks again bro. Jesus loves you man. :).


New member
Thank you Jpsaner for posting this. I appreciate it. FYI, I did have a slight problem with Step 5.

5) Climb left 8 steps

For me, it was 7 steps that worked, while 8 was one too many.

Thanks again.

Fanatic 64

You know how much time Link spent sealed in the Temple of Time? Well, that's how old this thread is.