What's new

Windows Media Player plugin is crashing my Internet browsers


Emu64 Staff
The title is kind of self explaining, but anyway : whenever I try and load a WMV/ASX stream with the WMP plugin, my browsers crash, be it Firefox or IE. In fact, WMP crashes as well. I use the latest WMP.


Keeper of The Iron Tail
argh. I have the same problem. I've seen it occur on one site only so far, with embedded WMV's (using the <object> tag). I've tried disabling the WMV plugin in the firefox options which doesn't fix it. IE6 and Firefox 1.0 both crash.

One thing I do have is Media Player Classic handling all my default .wmv, .avi, etc. extensions. I thought MPC might be causing the crash but it seems you use WMP and it crashes. MPC can actually play the .wmv's fine if i save to harddrive and open them directly. Perhaps i should look into having MPC replace mplayer2.exe (i believe the browsers use this as the plugin) altogether...


Active member
Can you reinstall media player? If not, do you have XP and "system restore" to roll back before you installed the latest WMP?


Keeper of The Iron Tail
hm, since opening WMP gives me a shiny "Thank you for installing Windows Media Player 9" screen/wizard, and I've never installed/touched WMP, I'm going to guess that SP2 installed it for me, in which case I can't roll back =P.


Keeper of The Iron Tail
Problem solved!

A few things I've found:

Opening WMV's in WMP 6.4 or MPC work fine. WMP 9 crashes.

WMP 9 is now the default media player plugin for web browsers; you can tell by the skinned interface in embedded movies. I'm fairly certain WMP 6.4 (mplayer2.exe) used to be the default plugin for web. In any case, this would explain the crashing of the web browser.

Windows Media Player is considered a vital part of the OS. If you delete or replace wmplayer.exe or mplayer2.exe, Windows (XP) will automatically restore the files completely silently from your system32\dllcache folder. Note that if you delete the file from the dllcache, there are a number of other places that XP will look to copy the file from, including paths like WINDOWS\$NtServicePackUninstall$ that hold the the previous version of WMP, in my case WMP 8. If Windows decides to restore this file, it will break WMP altogether as you are using a WMP8 exe in your WMP9 install. This will give you the fun error message "An internal application error has occurred". In some ways it is better than the outright crash. :happy:

Even if you delete all the backup versions of the files (Windows will let you know when this happens and prompt you for your CD - how nice =P), replacing the exe's with MP Classic doesn't seem to do anything to the browser. I could have sworn I'd heard of people doing that before, or possibly I'm just hallucinating.

Anyway, here's the (a?) solution. I searched a long time, but couldn't find anyone who solved their problem. However a common suggestion was to remove "illegal" codec packs. Now, the phrase "illegal codec" made me doubt if their intelligence was any higher than a monkey's, so I just ignored them for a while. Eventually I did try uninstalling Matroska Pack (not illegal), and it fixed it. It definitely seems to be a codec conflict that WMP9 can't handle. The pack contained MKV splitter, Realmedia splitter, ffdshow, VSFilter, CoreAAC, CoreVorbis, CoreFLAC, AC3Filter, MatrixMixer and Morgan Stream Switcher. Some of these are kind of useful, so I'd like to find out exactly which one causes the problems.


I had that Error a month ago. I could fix it by re-installing the WMP from the SA-DX or the Zoo Tycoon CD, the version i've downloaded from Microsoft Windows Uptade didn't work.