What's new

Jnes 1.0 graphics bug


New member
In the game Zelda 2: The Adventure of Link, the world map looks really messed up. It looked absolutely fine in v0.6. I've tried messing around with all the video settings, but nothing I've tried has fixed it.

Here's a screenshot: http://img182.imageshack.us/img182/6561/snap0000ii4.png

Here's a screenshot from v0.6 of how it should look: http://img340.imageshack.us/img340/8293/snap0001ln8.png

I'm no ROM expert, so I don't know what's specifically causing it. However, I tested the ROM with RomCenter, and it said that it was in fine working condition. It also works fine in Nestopia.


Emulator Developer
I gave the zelda 2 (U) rom I had a try with no issues, can you post the file name of the rom you are trying to use ? region ? etc. also would be interested if you were trying to restore a save from a previous version, that might not work.


New member
RomCenter recognized it as: Zelda 2 - The Adventure of Link (U) [b4].nes

Starting from scratch, no saves.


Emulator Developer
Well at least we found out it was one of the so called "bad roms", and it's interesting to know that it use to work in a previous version.

Gent got ahold of this particular ROM for me and it ended up being a bug I will fix for the next release, the fregen rom has 14 video banks, eww, that's why it's bad I suppose!

Anyway thanks everyone for the great discussion.
Last edited:


New member
Hi, sorry to hijack the thread but I seem to be having similar problems.

The version of JNES I have is the latest (1.0?) and the game I'm playing is Mother. Blocks of text seem to be missing everywhere.

I got the ROM from Rom-World.com. When it gave me these results I downloaded the second copy from that site but the outcome remains the same.

Any ideas?



The Great Gunblade Wielder
Sorry can't help you since you told us where you got it from.

My bet is its the fact its a J version which Jnes doesn't always fully support though.