What's new

ip.bin / syscalls.bin / writemem / Write to System Control Regs errors


New member
I've done all kinds of searching over as many forums as I could over the last couple days, and only find threads that are incomplete or long abandoned. Here's the log in png form, since I couldn't copy/paste it:

Edit: re-upped

I made that "Applications" folder to avoid read-only and permissions issues I'd experienced in the past with other emulators. I also tried the "Take Ownership" method to completely fix read/write problems, gave every type of user imaginable full access, installed, removed, and reinstalled the DirectX and C++ SDKs, runtimes, redistributables, etc... all to no avail. I also tried downloading multiple different versions of the .CDI ROM I've been trying to open (Gauntlet Legends), but the errors don't change. Attempted to mount using Daemon Tools, converted it to a .bin and opened from there, and swapped out the BIOS for different ones a bunch of times, but still nothing.

I get to the splash screen every time and Maple recognizes my controller right away, but I can't get the emulator to play the game. When I swap the disc through the Options --> GDRom menu, I get this:

--CDI toc info start--
Last Sector: 298837
Session count : 1
Session 0:
Track Count: 1
Session start FAD: 150
track 0:
Type : 1
Start FAD : 150
2 indexes
index 0 : 150
index 1: 298687
Disc Type = 16
--CDI toc info end--

...and then I get the same "Write to System Control Regs, not implemented" error repeated a bunch of times again.

I'm using the nulldc1.0.4r150 that mike177 from this forum compiled, downloaded from EmuCR.
My system is an Acer Aspire V5-753 laptop with a quad-core i7, 6 gigs of RAM and Intel HD GFX 4400.

The emulator speed seems fine without a game playing, and sound and input are perfect. I'm not sure how active this forum is these days, but please try to help me out! The n64 Gauntlet Legends emulation doesn't really work and I know there are some issues with the PSX version of the game itself as opposed to the emulator.

If I've left any info out, just ask and I'll add it in ASAP. Any small suggestions are welcome. Thank you!!


  • null1.png
    45.2 KB · Views: 406
  • null2.png
    47.5 KB · Views: 355
  • null3.png
    24.4 KB · Views: 361
Last edited: