What's new

Hello, only getting 25 fps in Skyward Sword and other games but specs are great


New member
I really need help and every time I try to post it says post denied, so I'm not sure what to do.

Edit: I keep trying to post my specs, the games I'm having trouble with, all that stuff, but apparently my posts have "forbidden words." What can I do?
Last edited:


New member
I don't know what to do, I can't ask for help properly for anything I need help with, it keeps saying my posts are forbidden. I tried messaging members privately who seemed knowledgeable about the issues I'm facing, but no one's responded, I somehow doubt the messages are being sent.


16-bit Corpse | Moderator
Can you describe in a roundabout way what exactly are you typing in your posts? If you can post a reply like the one you just did, there's something in the contents of your actual post that the board forbids.


Texture Pack Invader
It may be that as a new member you are still on probation. A few more posts on your behalf should do the trick.


Active member
Posting this on behalf of irrelevant_p:

Thanks Martin!

My specs:

Operating System: Windows 8.1 Pro 64 bit

Processor/CPU: i7-4770K CPU @ 3.50 GHz (8 CPUs) ~3.5GHz

Motherboard: Gigabyte GA-Z87X-UD4H ATX

Video Card/GPU: NVIDIA GeForce GTX 980 Ti

Memory/RAM: 16 gb

Power supply: Coolmaster GX II 750 W

Dolphin Revision Currently Using: Dolphin 5.0-rc-34

Here's an imgur link with all my Dolphin settings http://imgur.com/a/x2P34

I am only getting 25 fps in Dragon Ball Z Tenkaichi 3 and Zelda Skyward Sword at 1080p. I get 50-60 in 1080p with Super Mario Galaxy.

I recently upgraded my GTX 770 to a 980 TI, and despite what everyone told me, there was a huge jump in performance. Everyone told me that the 770 was enough to play Dolphin smoothly in 4K, but I could barely play 1080p. I just thought I'd mention that to give some perspective, for some reason my computer has had a problem with Dolphin.

Some things I've tried:

Checked Skip EFB Access, tried the latest dev revision, and also tried a different game. I also unchecked Force NTSC-J and tried Direct3D, which was much worse. I've also gone into my Nvidia Control panel under manage 3D settings, and under Dolphin and Power Management mode, selected "Prefer maximum performance," with no change.

Thanks for reading. It would really help me out if you knew of any suggestions.