What's new

Goemon's Great Adventure Working.


New member
This is just to inform anybody who is struggling to get Goemon's Great Adventure (U) running to a playable level on an emulator, it may or may not help but I am posting as this ROM seems notoriously difficult to set up in emulators.

I was really struggling to get this game to work as when it did run smoothly in Rice, the underwater levels were distorted and unplayable. The default 1964 video plugin was laggy at best and had the same underwater level problem as the Rice plugin as well as being unresponsive.
Mupen64Plus' Glide 64mk2 gave a blank screen despite me installing the latest graphics drivers.
I used Mupen64plus and Project64, before using 1964 1.1 at these settings:
Video- Final version of Glide64. Just look for the latest Glide64 plugin,
1. Make sure you extract the .MO, .ini, and .dll files to the 1964 plugin folder
2. You also should extract the glide3x.dll from the Wrapper folder from the Glide download into the same directory where your 1964 exe is.
3. Also in the Glide download there is a folder called '1964 Rom Ini for Glide64 version 5'. Follow the instructions given by the readme.

Audio- Shunyuan's HLE Audio 1.8.2
Input- NRage's DirectInput 8 v2. 80a. I am using a wired Xbox 360 controller. When configuring NRage, the plugin should detect the said controller. I can't say much about PS3, PS4, Xbox One or N64 controllers but for me, the PS3 pad was slightly harder to set up.

As mentioned earlier, make sure your graphics drivers (the ones from your card manufacturer) are up to date.
Laptop specs: HP Pavilion15-p264na
Processor: AMD A10-4655M APU
Graphics card: Radeon HD Graphics, 2.00GHz
8gb ram
64-bit Windows 10.

I apologise if this does not work for everybody. Feel free to reply if it is working or not, as it would help other users.

Credit to v1del from the Mupen64Plus message board who tried to help me get it working with Mupen64Plus and mentioned the tip about updating graphics drivers.

Edit: If using Glide64, check that you are using DirectX and not OpenGL; I believe that is why I got a blank screen. Also, the underwater levels use framebuffer effects so whatever video plugin you are using that works fine for you, make sure that framebuffer effects are enabled in some way.

Occasionally on Rice and Glide64, you might get a laggy performance from the menu screen onwards. I don't know about you, but this does not always happen and if it does you could shut down the emulator and start the rom again. What worked for me was changing it from windowed to fullscreen and vice-versa until the rom played at it's normal framerate.
Last edited:


New member
Well glad you got it working somehow, but still this is weird... If glide64 final works glide64mk2 should work as well might be something to look into once I update to 10 (given that it happens then as well? :p


New member
You're right, it is weird.. until I realised that Glide64mk2 was probably set to OpenGL instead of DirectX, which I did not really pay attention, and that is maybe why I got a blank screen. As for the Rice plugin, I have partially solved the underwater problem by activating Basic Framebuffers; it seems that this game uses framebuffer effects for those levels.

Unfortunately on Rice there is a tremendous amount of lag although it is now playable; I have tried playing with the Normal blender/normal combiner options to no avail. On Glide64 (not mk2) the game refuses to transition to the underwater levels and hangs on the 'darkening' screen as you transition, but will never display the new underwater area, despite playing the correct sound (this is with the framebuffer on). Now that I know the underwater level uses framebuffers, and I need to use DirectX, I don't know if Glide64mk2 still works as I deleted Mupen64plus before thinking that it will never work.

If you know a way to stop the underwater levels lagging on Rice, or get them working on Glide64 please do post it in a non-emulator specific message board as Project64 can use Rice and Glide64 too. I'll add an edit to my above post for the new information. Sorry for the disappointment!
Last edited:


New member
glide can only use OpenGL if you use the wrapper provided by it (or glide3dfx, which you probably aren't using anymore) if glide64 final works, OpenGL works fine for its purposes that's why I think it's weird that mk2 would get problems