What's new

glN64 problems with ATi Catalyst 3.8 & 3.9

The Khan Artist

Warrior for God
I just upgraded to Catalyst 3.9 (from 3.7), and lo and behold, glN64 stops working. All it displays is a black screen. So, I tried Cat 3.8, and it did the same thing. 3.7 works fine. I grabbed the atioglxx.dll from 3.7 and reinstalled 3.9, then put it in the 1964 folder. It works.

I'm using 1964 0.8.5 and Mupen64 0.3. My system is in the system area.


Cat 3.7: Works perfectly.
Cat 3.8/3.9: black screen
Cat 3.8/3.9, with the atioglxx.dll file from Cat 3.7: Works perfectly.

It would appear that ATi has changed something in their OpenGL implementation that breaks glN64, at least on my system. Has anyone else experienced this?
Last edited:

Moose Jr.

Raging Moose
I have the same problem, but I haven't tried the fix you described (good thinking, btw). However, I did get it to work by turning Frambuffer off. I wish I knew what the problem is.
The Khan Artist

The Khan Artist

Warrior for God
BAD NEWS!!! You are not alone. The ViaArena message board, in the ATI Arena section has a post about the Catalyst 3.9 drivers breaking OpenGL and that the
other OpenGL games will fail to init, also. It's probably not a glN64 problem.


1) That issue only affects Cat 3.9. glN64 has problems with 3.8 as well.

2) That issue only affects All-in-Wonder cards. Moose Jr. does not have an All-in-Wonder card, yet he has glN64 problems as well.

3) I already have the OpenGL hotfix for 3.9, anyway. Other OpenGL things run fine, it is just glN64.

Anyway, turning off framebuffer does indeed fix the problem. Thanks.


Emutalk Member
I haven't installed catalyst 3.9 yet but 3.8 broke the framebuffer effects in pete's ogl plugin (PSX). And the glN64 hardware framebuffer textures enabled shows black screen as you already mentioned. Seems like a framebuffer problem :ermm: I was kinda hoping they'd fixed it in 3.9, but apparently not :cry:
Bad ATI, bad!

But Khan, thats a good tip using the atioglxx from 3.7, have to try it out.


Hi- I upgraded my catalyst 3.9 to 3.10 and now i have the problem that my Pj64 SP1 totally hangs up...
with 3.9 it works and now
It's dead! Is there any way to fix it?
I want to play NFSU too, and on catalyst 3.9 it is stocking