What's new

filtered output doesn't work


New member
Hey all~
Hopefully somebody still reads this stuff --
anyhow, lately I've been having trouble with Jnes, I cannot get any video out when a filter is applied. This is true for all filters, software, super2xsai, and the nes_* filters. Are there any ideas as to why this happens?

My system specs:
Windows Vista Service Pack 2 (32 bit edition) --> all updates done
--> nVIDIA drivers 190.62 (as of 9/11/09 the current is 190.62)
nForce4 with latest chipset drivers (as nForce4 is no longer updated...)
There are no directx conflicts (via dxdiag)

I doubt the video driver is an issue, I will try to update it but I expect the same result. My tech knowledge is quite high (I hold a bachelor's degree in computer science) and without going thru the source myself I don't know what the problem could be. If anybody has any ideas (especially Jabo!) please let me know. Without any kind of filter the renderer is quite slow --> you can see pixel tearing, even if vsync is enabled. In fact, vertical sync makes it worse (not a great idea on an LCD anyway) but I'm trying every combination of options I can.

The emulation is still running without issue, it's just the video that is borked. You can theoretically play a game (I was playing paperboy haha) without the video but it's quite difficult.

Big thanks in advance to anybody with insight and please, if I forgot to mention something that may be of importance don't hesitate to request!

I forgot to mention, there is no video output in both windowed and full screen mode
updated drivers, same result as expected
Last edited:


New member
Just wanted to chime in and say the exact same thing is happening to me as well. I'd heard good things about JNES and wanted to try it out, but unfortunately it's essentially non-functional in terms of video output when in filtered mode.

BTW: Other NES emulators work just fine, this problem only happens in JNES.

My specs:
Intel C2D E6400 @3.2ghz
8800GT 512mb (latest WHQL driver)
Windows XP Pro SP3

Tried version 1.01 and version 1.0, they don't work for me. :(


filtered output doesnt work

Whenever I activate the in-game menu in Pokemon Diamond, the game locks up. If I try to return to the game, I just get a white screen with some noise coming out of the speakers. Same thing if I try to return to the firmware menu. Anyone else having this problem?