What's new

Dolphin Final 1.03.2 x64 Public Beta (single/dualcore support) - Shots

Falcon4ever

Plugin coder / Betatester
*** POST HERE ANY SCREENSHOTS YOU HAVE FROM THE LATEST x64 BETA 2 release ***

Please state your system specifications and performance in Dolphin64
 

emwearz

New member
The Legend Of Zelda : The Windwaker

Using the Dualcore build with dynarec enabled, specs in my sig.

The game runs pretty solid with lows of about 15 and highs of about 30.
 

emwearz

New member
Wario World

Using the Dualcore build, with Dynarec disabled.

The speeds are a solid 15fps.

Please note this game appears full playable other than the screen not running in fullscreen and the fact it must be run in interpretor mode.
 
Last edited:

HyperIris

New member
Super Mario Sunshine

AMD X2 3800+ no oc
2G DDR2 667
NV 7300GT DDR2 256MB no oc

Windows XP pro x64 + sp1

Using the Dualcore build with dynarec enabled.

6~~15 fps in game, mario looks strange.
 
Last edited:

HyperIris

New member
Paper Mario TTYD

AMD X2 3800+ no oc
2G DDR2 667
NV 7300GT DDR2 256MB no oc

Windows XP pro x64 + sp1

Using the Dualcore build with dynarec enabled.

about 20~~40 fps in game( in fact, the game in ngc console is 30fps),
can not into first battle.
 

BlueFalcon7

New member
Sonic adventure 2 Battle:

Specs:
CPU - Intel C2D E6600 (2.4 GHz)
GPU - GeForce 7900 GS
RAM - 2GB DDR2 800 PC2 6400

About 30 - 60 FPS averages in the low 50's
For the most part fully playable. Sound works fully, Sound effects, not so much.

Note: The game kept crashing on city escape, but on dark side, it worked fine.

Great Job!
 

decription

New member
Absoluetly MEGA guys! I had a feeling dual core and 64bit support would be the missing link towards better speeds but these type of results are even better than I imagined.

I'm just waiting for a reply from someone with a quad-core. All in all not exceptionally surprising given the team behind Dolphin. I guess this also makes dev work easier as you don't need to wait 20 minutes to get past an intro anymore.

Hat's off! I might have some screenies in here in a bit.
 

BlueFalcon7

New member
I'm just waiting for a reply from someone with a quad-core.
They don't want to do that, because it will make more games fully playable

Oh, and I realized that the version I was using was Beta 3, for some reason Beta 2 doesn't seem to work properly.
 

classic leon

New member
The FPS are between 24-66. That's freaking awesome!!!
Game title and the first video can be displayed. but I can't get any chance to get in-game thing, including the demo (it crashes if you don't touch the pad for seconds on the title screen). No audio.

My rig is
AMD FX-60 Dual Core
4GB DDR400
X1900 CrossFire Edition
1TB Raid 0 Stripedx4 Dard Drive
X-Fi Elite Pro
Windows Vista 64 Bit
 

enix-sama

New member
I used beta3 for these, performance was a bit better than with beta2.

I use an AMD Athlon x64 3400 2.21 ghz processor with winxp 64 w/ sp2.

Most of the games I could run on the 32bit version still work and with twice the performance. I couldn't get pokemon coliseum to run and got a humorous error when I tried running naruto 4 (error- not good, time to pray).

Zelda: TP is much more playable now (8-13 fps ingame) and maybe even more so on dual core (I don't have my dual core system set up :( ).

DBZ: B2 is much more playable (10-15 fps ingame), and super fast on loading and on all menus, even keeps around 30fps on the character selection screen when the 3d models are being displayed. Also, the sound is basically perfect.

Sound works on Shadow the Hedgehog, but I didn't hear any on the others.

I tested 5, only 3 worked (well I got a bit impatient on pokemon)
 
Last edited:

BlueFalcon7

New member
OK, I tested the USA version if Super Mario Sunshine
Framerates were all over the place.

Outside, it was about 8-18
Videos, around 35
Level select, around 70*
Bonus levels (where you hear the really cool Mario music, and fighting pety piranha), around 15~25 FPS

No sound. However, I did notice a few weird things.

First of all, when I first got the FLUDD, it gave me a weird message like "DBAT WTF" and Fatal error; continue? I selected yes, but it froze. I went in and played again, and I didn't get that message. It also happened when I beat the boss on Delfino airstrip. It was after I saved, so I played again, and it continued. Then I played, and it was slow, but it played. Here are some screenies.

*I think the game is meant to be only 30 FPS, however, in level select, its meant to be 60 FPS. Im still figuring that out.
 
Last edited:

enix-sama

New member
Alright, I can defiantly confirm the report that Super Smash Bros. Melee is basically fully playable now.

I only get 10-20fps ingame but it feels like it's enough, I can actually play competitively.
 

BlueFalcon7

New member
Alright, I can defiantly confirm the report that Super Smash Bros. Melee is basically fully playable now.

I only get 10-20fps ingame but it feels like it's enough, I can actually play competitively.
For me, it goes around those speeds, maybe a little faster, but even slo-mo melee plays too fast for me. Its like everyones on speed (if they werent before :p) THis game could use the frame limiter the most!
 

cooliscool

Nintendo Zealot
The Legend Of Zelda : The Windwaker

Using the Dualcore build with dynarec enabled, specs in my sig.

The game runs pretty solid with lows of about 15 and highs of about 30.

It's running much faster here - 29FPS at the "Link Awakens" scene. Are you running Vista (X64 Pro here - stripped down to nothing)?
 

thepreserver

New member
It's running much faster here - 29FPS at the "Link Awakens" scene. Are you running Vista (X64 Pro here - stripped down to nothing)?

At the time emwearz posted this, he was using Beta 2, but soon after Beta 3 was released since Beta 2 wasn't the latest Dolphin x64 build.
 

cooliscool

Nintendo Zealot
Some shots.. as others have said, 30FPS is definitely fullspeed in WW.

16xFSAA, 16xAF.

clipboard01aw7.png


clipboard03iq9.png


clipboard05nk1.png


clipboard06rc2.png


clipboard02pr6.png


clipboard01wx3.png


And... E3 Outset Island. :)

clipboard04qn9.png
 
Last edited:

lightchris

New member
Some shots.. as others have said, 30FPS is definitely fullspeed in WW.

16xFSAA, 16xAF.

Great fps there. So you are running XP 64? Maybe it does make a difference. I have Vista 64 and get roughly the same speeds as emwearz on my C2D @ 3.15 GHz and a 8800 GTS.
 

Top