What's new

1964 1.2(Unofficial) - Release Topic

FrankN64

New member
Thanks ^.

I have found a couple more issues with TWINE and the 2.7 audio plugin. I'll add it to my previous report on the googlecode later.

The glitch i reported above occurs on King's Ransom level instead of City of Walkways II when using Jabo's new Direct3D8 1.6.1. And there's an annoying graphics error box 'InitiateGFX called without CloseDLL', everytime a rom is started.

Sound gets muted at random points for no apparent reason anywhere in the game, start menu too. Sometimes just making a quicksave brings the sound back, without needing to load the quicksave back.

I'm guessing the 1964 Audio 2.7 isn't using the Zilmar specs, as it doesn't work in Project64. Which is a pity as its the only plugin that does the speech.
 
Last edited:
OP
death--droid

death--droid

New member
Moderator
Thanks for all the error reports, the 1964 Audio 2.7 is kinda way above my level of programming and I don't have the knowledge of how its designed. It wont work with Project64 because of the different way it has audio fed to it I'm pretty sure, not completely sure on that one though XD

Hopefully going to have the language system a bit fixed up in my next commit... though its going to need the translations redone.
 

FrankN64

New member
I think the 1964 Audio 2.7 is the most advanced plugin of them all. But it just isn't quite perfect in use. Probably needs a re-write, as it has had a lot of functionality added or patched on since the original version. Its almost the perfect audio plugin. A re-write following the Zilmar specs would be ideal. But who to do it?
 
OP
death--droid

death--droid

New member
Moderator
XD, im pretty sure it would also require a rewrite of core code of Project64 to also to get it work since it has support for the MusyX audio.
Anywayyy, committed the translation fix to the repo, I removed all the other languages so they will need redoing, if anyone makes a translation just send it to me or make an issue on the google code page and ill commit it to the repo.

Just out of interest, is anyone interested in wiimote support for the input plugin?
 
Last edited:

The Siskoo

Member
Here the french translation.

There are some strings/translations problems.

1964 - Window Tab picture : translations doesn't applied.
1964 - Plugin Tab :
  • Red part : About are replaced by others strings
  • Yellow part : this string doesn't exists.
  • Blue part : do you think it's possible to resize ?
 
OP
death--droid

death--droid

New member
Moderator
Thank you for the report The Siskoo, I'll try getting everything fixed up as soon as I can, thank you for the bug reports and suggestions, and it should be fine to increase the size.

@LazerTag, Ill try to get work onto it, I'll be able to write up a basic implementation but I have no bluetooth dongle or classic controller, I only have a wiimote and the nunchuck at the moment. And at the moment I have no income, so it will be awhile before I get it commited to SVN.
 
OP
death--droid

death--droid

New member
Moderator
@The Siskoo, everything you have asked for to do with translations has being completely fixed up now, hopefully you shouldnt run into any problems with it any more. Also committed your French translation to the repo, thank you very much for that.
 

The Siskoo

Member
Thanks. There are more problems :

- 1964 - Double Exit pictures : there are 2 Exit option in the file menu.
- 1964 - Window Tab picture :
1) Windows Behaviour displays How many? strings
2) Start Rom in full screen displays Pause When 1964 Window Is Inactive strings
3) Counter, Profiler, disabled displays Status Bar Monitoring, counter, profiler
- 1964 - Plugins Tab : Display Default plugin plugins displays Input

There is a king af refresh screen problem, here the steps :
- Launch 1964
- Choose French
- Choose English
- Edit --> Cheat Code --> Plug_ins --> System Default RSP Plugin and you'll see austalia.
 
OP
death--droid

death--droid

New member
Moderator
I swear i fixed that exit problem..., thank you for more reports. Hopefully ill get this all sorted out ASAP

EDIT:
Fixed the windows tab and the plugins tab.
Just need to fix the exit button :\ and the weird refresh bug
 
Last edited:
OP
death--droid

death--droid

New member
Moderator
Can someone provide me with a texture that loads when TMEM-Emulation is off, but doesnt load when its turned on, working on a fix to 1964Video to make all texture packs load no matter wether they were dumped with TMEM-Emulation on or off.
 
OP
death--droid

death--droid

New member
Moderator
Beign a bit busy lately sorry, I've got holidays in about a week so ill try and get some stuff done then.
 
F

Fanatic 64

Guest
Can you get 1964Video working on Windows 7 x64? It still says "Cannot initializa DX9" and "g_pRender is NULL".
 
OP
death--droid

death--droid

New member
Moderator
1964Video should work fine with Windows 7 x64, its what i use it on.
On another note, I'm likely not to be doing anymore work with 1964 Emu, I'm don't really know that much about programming at all, and to be honest it requires someone who really knows what there doing to fix some of the finer problems with it.
 
F

Fanatic 64

Guest
I found the problem was using FSAA... jaja. Anyway, this was a nice derivation project from 1964.
 

Top