Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    EmuTalk Member
    Join Date
    Apr 2016
    0 Post(s)
    Quote Originally Posted by Twoflower View Post
    I figured out the source of (at least my particular version of) the problem.

    VJoy. It's a virtual joystick driver which normally is quite well behaved, but seemed to have gotten its little virtual stuck jammed upwards, causing any games which automatically use any controller currently "plugged in" to freak out and hold up as well. That includes Demul, apparently, because once I uninstalled the little ******* Demul was perfectly happy to let me remap anything without issues.
    I don't have anything like that on my computer. I even tried it on an older Windows 8 machine to no avail. If MetalliC can give me the info on the dll I mentioned above, I'd really appreciate it.

    - - - Updated - - -

    Ahhh... I figured out the cause of my problem. On my special controller, by default, the z-axis is set to the maximum value and as you move it, it lowers. I could use something like vjoy and ujr to configure a virtual joystick to fix this but I think demul will pick up any controller input so when I connect the joystick, it'll pick up both the real joystick and the virtual joystick. There is no way in demul to specify the controller number to receive input from (I don't think). Anybody have any further ideas? Bseides the dll one I thought of before?

    Edit: Just thought of something. Is there a way to get a listing of the axis and button values so I can manually set them myself in the ini file?

    Edit2: I thought I finally had this figured out. I used vjoy to create a joystick with a virtual x and y axis and then used the feeder app (test control app that comes with vjoy) to set the variables in the demul config utility. It sets the values to things like JOY0_ANL2_KEY and JOY0_ANL1_KEY for both left/right, up/down respectively which doesn't look right. When you use an xbox 360 controller, they are all separate values. Also when you start the game, the control plugin throws an error. I'm thinking it just doesn't like this type of generic controller. It has to be xbox 360 compatiable controller. If the developers are willing to try out Vjoy, it is reproducable now but I don't know if they have the time to bother with it.
    Last edited by Potbellypig2000; April 21st, 2016 at 23:48. Reason: new though

  2. #12
    EmuTalk Member
    Join Date
    Jan 2015
    0 Post(s)
    i second vouch for a fix for support for direct input controllers.

    i have a ps3 to PC convertor ( http www mayflash com Products PCUSB PS3003.html ). it has a xbox/dinput switch. if i use xbox then it only supports 1 controller.
    if i use dinput then it allows 4 controllers.

    we need dinput for 2-4 controller support.
    but demul doesnt recognise dinput


    UPDATE: funny
    somehow last night it worked! demul ws able to detect my Dinput controllers so we were able to play with 2 controllers! yippee!!! demul is the best emulator ever!
    Last edited by andwan0; September 26th, 2017 at 10:32.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts