PDA

View Full Version : VBA problems



Doomulation
June 25th, 2003, 22:07
I dunno, but...the emulator is so slow! Using it, whatever I do, I must use frameskip 1 to keep the speed of the emulator...
And the sound - it's horrible! It crakles at times all the time! May it be because of the frameskip?
Could it possibly speed up a little if I were to disable the filters perhaps?
But dammit - on my computer, it shouldn't lag!

For those who don't remember, my cpu is an AMD Athlon 2000+.
I suppose that some games can require more power, though...Golden Sun 2 is 16 mb unzipped, which I'm playing.

Clements
June 25th, 2003, 23:32
When I use VBA, I put it on a frameskip of 1 as well. I suggest you try out the D3D and OpenGL render methods instead of DirectDraw. They seem to be much smoother for some reason. Disabling filters won't increase speed very much at all really.

JuGz
June 26th, 2003, 10:25
Hey Doom, I got the same prob of you and i got the same cpu as well.. :(

Doomulation
June 26th, 2003, 16:13
Yes, it's a mystery...

The Khan Artist
June 26th, 2003, 17:20
Try using the GDI renderer.

I can run almost everything at 100% full speed with no frameskip, Bilinear Plus filtering, and 44 KHz sound. But with any other renderer, it went horribly.

Doomulation
June 26th, 2003, 18:36
Hmm ok, I'll try!
EDIT: No go :bye3: Direct3D works best, yet still slow. 80% with filters; 140% without.

ScottJC
June 30th, 2003, 14:51
I have this problem also, and my hardware isn't exactly low end either, try setting priority to above normal or highest, that seemed to fix my issue.

it seems XP allocates less cpu sometimes to VGBA for some reason...
*continues playing advance wars 2*

Doomulation
June 30th, 2003, 16:33
Set to highest setting already :|

ra5555
June 30th, 2003, 17:00
That is really werid. I only have an XP 1700, yet I never had any slow down in VBA. The frame skip is always at 0, I get 400-500 percent when I press space and thats with AdvanceMameFilter and Low pass audio filter on. You can try enabling Use Video Memory and Triple Buffering, and see if they help:

Doomulation
June 30th, 2003, 20:41
...
Oh and removing echo and low pass filter doesn't change anything.

Lillymon
June 30th, 2003, 20:53
Try setting the throttle to 100%. Or set it to Custom and make sure Custom is set at 100%. It may sound strange, but give it a try.

ra5555
June 30th, 2003, 20:57
hmmm... Did you a BOIS file? I have hear using it can cause slow downs, try disabling it.

EDIT: oh you can also try auto frame skip, that should give you 100%

Lillymon
June 30th, 2003, 21:06
I had problems with auto frameskip giving me jerky, slow emulation. I fixed it. I can't remember how, but messing around with the frameskip options should duplicate the solution.

Doomulation
June 30th, 2003, 21:50
Everything seems to fail :cry:
Auto frameskip: 0 is also checked and i get jerky emulation.
Throttle: still jerky
And I'm not using bios since the save games were made without them (curse vba for not making you able to load non-bios savestates and vice versa without using or using the bios depending on what, well you get it).

loleoc
July 3rd, 2003, 22:53
The best settings for me (vba runs at 99 or 100%)

Directdraw render
Ddraw uses video memory (much better)
Triple buffer disabled (i dont know why)
640 * 480 fullscreen
sound 44 khz
Priority normal
no bios file
frameskip set on 1
Sync enabled

Ah! in Control panel, in Sound Configuration I put Frequency of sampling on "Good", since it does not require the use of the processor for sound.

With this settings the games runs perfectly and the sound is good (on my onboard via ac 97 onboard sound card with 3.5 c drivers (the latest).

loleoc
July 3rd, 2003, 22:57
Sorry, vsync disabled. There is another sync that I have been enabled, because the emulator runs at 143%!!!

gamerk2
July 4th, 2003, 05:10
I had the same problem, but here's how to fix it:

Frameskip:
1) TURN OFF AUTO-FRAMESKIP-its definatly too slow
2) change frameskip to 0
3) select no throttle:works fine for me
Vidio:
1)turn of v-sync: it can slow games at some points (i have a pentium 4 w/ 512 mb ram-trust me on this)
2) render method-direct draw works fine for me
3) i use ddraw triplebuffering
4) d3d nerest enabled
5) gl nearest and gl triangle enabled
Emulator:
1) synchronize enabled
2) bios file enabled
Sound:
1) enabled (no other options besides soundchannels and 44 kHs enabled)
Priority:
1) normal
Filter:
1) normal
ALL OTHER OPTIONS NOT MENTIONED DON'T MATTER OR ARE SET TO OFF!!

I hope to have a screenshot shortly to better show my options.