What's new

What settings would you suggest to run Dolphin at 1080p w/ minor to no lag/stutter?


Head Honcho
Just as the title states I want to run Dolphin at decent speeds and high res without any hangups with the rigs in my sig. Currently, I'm using Dolphin v4.0-2032, x64 to play the GameCube but the visuals look ugly on my 42" 1080p screen (anti-aliasing must not be working). I've mainly seen it action on my 2nd rig (w/ the i7-980x) but I would like some help in adjusting the settings so that these games could scale well according to my screen's resolution. Any helpful feedback is appreciated.


Head Honcho
The "latest" version is always here, always at the top -> https://dolphin-emu.org/download/

Thanks for the suggestion. I realized that my games were looking a bit jagged on the edges b/c for some reason the 'Anti Alias' setting never did save. I tinkered around with the settings and things look better but not high def like I was expecting; textures seem smoothed out as if Dolphin upsampled 480p, the original resolution of the game, stretching it to 1080p, my monitor's resolution. I'm trying to run Mario Kart: Double Dash but I'm coming across a problem where once the music changes, gameplay will momentarily stutter, come to a crawl and FPS will reduce before going back to normal. This is especially bad at the opening intro. Removing ingame V-Sync helped but not as much as I would've liked. The game is playable but for example when the music changes indicating it's the final lap, that's when the problem occurs. What settings can I use to reduce this stutter/lag as much as possible. The following are the settings I'm currently using:

In 'Config' setting:
Under 'General' section I checked
*Enable Dual Core
*Enable Idle Skipping
*Enable Cheats
Framelimit set to "Auto"
'JIT Recompiler' selected

Under 'Interface' section I checked
*Use Panic Handlers
'Boomy' selected

Under 'Audio' section
'DSP HLE emulation' selected
Backend Settings set at 'XAudio2'

Under 'Gamecube' and 'Wii' sections, left at defaults and set 'Paths' for rom directory.
Under 'Advanced' section, left 'Enable CPU Clock Override' unchecked *Could this help improve performance?*

In 'Graphics' setting:
Under 'General' tab
Set 'Backend' to "Direct3D"
Set 'Adapter' to "NVIDIA GeForce GTX480"
Set 'Fullscreen Resolution' to "1920x1080"
Set 'Aspect Ratio' to "Force 16:9"
Disable "V-Sync" and checked "Use Fullscreen"
Checked "Hide Mouse Cursor" and "Render to Main Window"

Under 'Enhancements' tab
Set 'Internal Resolution' to '3x Native'
Set 'Anti-Aliasing' to "8 samples (quality level 32)"
Set 'Antisotropic Filter to "16x"
Checked "Scaled EFB Copy"
Checked "Force Texture Filtering"

Under 'Hacks' tab
Checked "Skip EFB Access from CPU" and "Ignore Format Changes"
Set 'EFB Copies' to "Texture"
Set 'Texture' Cache to "Fast"
Set 'External Frame Buffer' to "Virtual"
Checked "Fast Depth Calculation"

Under 'Advanced' left it at defaults

- - - Updated - - -

I just solved my own question. After applying 'Enable CPU Clock Override' settings at 100%, the opening intro ran w/ no lag or stuttering.

- - - Updated - - -

I finally got the settings right and now my games are looking good. Check out the screenshots of Resident Evil 4 below in 1080p HD in it's pure beauty:









- - - Updated - - -

Mario Kart: Double Dash - Dolphin Screenshots






Last edited: