Page 1 of 2 12 LastLast
Results 1 to 10 of 15
  1. #1
    EmuTalk Member
    Join Date
    Dec 2012
    Posts
    4
    Mentioned
    0 Post(s)

    Demul is very slow

    Is it not possible to improve it?


  2. #2
    Demul developer
    Join Date
    Aug 2010
    Posts
    232
    Mentioned
    1 Post(s)
    PC specs ?

  3. #3
    EmuTalk Member
    Join Date
    Dec 2012
    Posts
    4
    Mentioned
    0 Post(s)
    I5 6600, 16gb ram, SSD hd and Geforce GTX 750.

  4. #4
    EmuTalk Member
    Join Date
    Apr 2005
    Posts
    12
    Mentioned
    0 Post(s)
    That is very interesting. You have a much faster CPU than I, but we have the same card. Everything runs fullscreen for me accept some pauses here and there that I think is cache related. My internal resolution settings is at 2x by the way, but I get a lot of slow down if it is windowed instead of fullscreen, but that is another story.
    Last edited by Yugi; April 28th, 2018 at 20:45.

  5. #5
    EmuTalk Member Hydreigon's Avatar
    Join Date
    May 2018
    Posts
    4
    Mentioned
    0 Post(s)
    Quote Originally Posted by Zazie View Post
    Is it not possible to improve it?
    Similar specs. My system runs Demul slow at all but instead caps the frames at 30fps as opposed to 60fps in any game than runs at 60fps. Idk what is the cause. Either an emulation timing bug or can't handle newer gpu hardware? Can't find anything regarding this bug.

    i5 8600k, 16gb ram, ssd installed on windows in addition to an hdd, and a GTX 1070 Ti.

  6. #6
    Demul developer
    Join Date
    Aug 2010
    Posts
    232
    Mentioned
    1 Post(s)
    can you provide clearer explanation of "works slow" ? during which game emulation it happens and what (not default) settings was used ?

    there is 2 typical causes, and I think it was told this 100 times already:
    - GPU drivers power management, to avoid this need to create profile for Demul and set there "Power management mode - Prefer maximum performance"
    - DX11old GPU plugin, don't use it, it is ancient piece of sh*t and may produce 1000s of glitches, crashes and other problems.

  7. #7
    EmuTalk Member
    Join Date
    May 2018
    Posts
    4
    Mentioned
    0 Post(s)
    Quote Originally Posted by Hydreigon View Post
    Similar specs. My system runs Demul slow at all but instead caps the frames at 30fps as opposed to 60fps in any game than runs at 60fps. Idk what is the cause. Either an emulation timing bug or can't handle newer gpu hardware? Can't find anything regarding this bug.

    i5 8600k, 16gb ram, ssd installed on windows in addition to an hdd, and a GTX 1070 Ti.
    This is exactly how it runs on my system too. FPS and RPS counter both show 60 but only every other frame is outputted on the monitor. It really is choppy. This is when VYSNC is off.
    I notice though that when you adjust audio buffer to lower values (lets say 1024), video is smoother but with really bad audio. When you set it to 4096, video output is like 15 fps. Might it be an SPU plug-in problem?
    With VSYNC on everything runs smooth but it introduces a lot of input lag.

  8. #8
    EmuTalk Member Hydreigon's Avatar
    Join Date
    May 2018
    Posts
    4
    Mentioned
    0 Post(s)
    Quote Originally Posted by kalawangman View Post
    This is exactly how it runs on my system too. FPS and RPS counter both show 60 but only every other frame is outputted on the monitor. It really is choppy. This is when VYSNC is off.
    I notice though that when you adjust audio buffer to lower values (lets say 1024), video is smoother but with really bad audio. When you set it to 4096, video output is like 15 fps. Might it be an SPU plug-in problem?
    With VSYNC on everything runs smooth but it introduces a lot of input lag.
    I would probably avoid using vsync on most arcade titles. Frames still lock at 30 with vsync on. I never use gpudx11old either except for games that don't support gpudx11. Also, prefer maximum performance won't even change a thing because I don't ever upscale games especially the arcade titles. I will have to agree with kala on this. Incorrect timing for cpu and sound?

    What gpu and cpu do you use kala?

  9. #9
    EmuTalk Member
    Join Date
    May 2018
    Posts
    4
    Mentioned
    0 Post(s)
    I only have a 2500k and a gtx 1050. Demul runs 60 fps buttery smooth with vsync ON, both with dx11 new and old. I dont upscale either. I just want proper timing and correct framerate, I dont even mind screen tearing. Yeah, syncing issue is my only guess.

  10. #10
    EmuTalk Member Hydreigon's Avatar
    Join Date
    May 2018
    Posts
    4
    Mentioned
    0 Post(s)
    Bumping. Still awaiting on if this is confirmed or not and if a workaround is available.

    P.S. My pc monitor is 144hz.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •