Results 1 to 3 of 3
  1. #1
    EmuTalk Member JKKDARK's Avatar
    Join Date
    Mar 2006
    0 Post(s)

    DC Load State doesn't work

    Just installed this emulator again. Games run fine but when I click Load State the emulator crashes.

    I'm using the latest version. Any way to fix it?

  2. #2
    EmuTalk Member emusa's Avatar
    Join Date
    Aug 2008
    0 Post(s)
    In the latest version of Demul load and savestates are kinda broken. You can only use them ingame during your play session, once you restart the game your old quicksaves are corrupted and crash the emu.

    Metallic once stated that "it was a miracle savestates even worked in the first place".
    CPU: Intel i5 3570k @4.2ghz
    GPU: ASUS GTX 780 @1140/6600
    SSD: Samsung 850EVO 500gb
    PSU: Corsair CS750M
    CASE: Lian-Li PC-Q08 CASE
    OS: Windows 7 x64

  3. #3
    EmuTalk Member
    Join Date
    Mar 2017
    0 Post(s)
    Hello i installed this emulator. The Games start nut whenI click on Load State the emulator not working..
    any help what to do??
    I had visited many website even used other wireless help but not solved.
    Dixita Patel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts