Results 1 to 4 of 4
  1. #1
    EmuTalk Member
    Join Date
    Feb 2017
    Posts
    9
    Mentioned
    0 Post(s)

    Huh? Weird problem w/ SFA3.

    Hey, guys! I am loving this Demul emulator. Question. Something weird is going on with Street Fighter Alpha 3 (USA) for the Dreamcast. The controls won't work at all. I've double checked, triple checked the Dreamcast button setup. The same goes for the Arcade button setup. I have no problems playing Marvel vs. Capcom 2 for the Dreamcast and Arcade. I can't figure out why the controls won't respond to Street Fighter Alpha 3 (USA) for the Dreamcast. Any ideas on what could be causing this?

  2. #2
    EmuTalk Member
    Join Date
    Feb 2017
    Posts
    9
    Mentioned
    0 Post(s)
    Whenever I start up SFA3 for Dreamcast, two VMUs would show up by the screen. They are labeled as PORT A VMU 0 and PORT B VMU 0. I am certain that these are the reason why the gamepad controls don't work.

  3. #3
    Demul developer
    Join Date
    Aug 2010
    Posts
    171
    Mentioned
    1 Post(s)
    "Dreamcast Controls not working" in 99.9% cases => you messed with settings, think you are smart and assigned DC Extended Controller buttons, because you think its cool to have as many buttons as possible.
    no, you are not smart and its not cool, there quite big number of games not compatible with such input devices.
    solution - revert buttons settings to defaults.
    Last edited by MetalliC; February 19th, 2017 at 21:57.

  4. #4
    EmuTalk Member
    Join Date
    Feb 2017
    Posts
    9
    Mentioned
    0 Post(s)
    Quote Originally Posted by MetalliC View Post
    "Dreamcast Controls not working" in 99.9% cases => you messed with settings, think you are smart and assigned DC Extended Controller buttons, because you think its cool to have as many buttons as possible.
    no, you are not smart and its not cool, there quite big number of games not compatible with such input devices.
    solution - revert buttons settings to defaults.
    >.< Oh, wow. You were right. Resetting the controls and leaving the Extended Controls blank did in fact fix the issue. Sorry for stepping out of bounds. This is and has always been my favorite emulator.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •