Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 50
  1. #21
    Retro Hoarder Imgema's Avatar
    Join Date
    Aug 2003
    Location
    Athens
    Posts
    38
    Mentioned
    0 Post(s)
    Hmm, some games that run fine with older versions seem to have stuttering frame rate now. First game i tested, Super Mario 64, was perfect before (smooth frame rate, no sound pop) but now it lags. I tried changing vi and ai but it still lags, although i have no idea what numbers should i put and what does what. I tried lots of different values and i can only make it go fast forward sometimes. The only thing that fixes lag is to uncheck the audio sync/timing options but then the sound pops. So i have to choose between smooth video or smooth sound. Same thing with other games like Waverace and Starfox. They all run at about 95% of normal speed which causes stuttering.



    I remember having this problem with some other emulators but never with PJ64... Is this fixable somehow?

    EDIT: It seems that disabling "fixed audio timing" without disabling audio sync fixes the problem with those games. I can have smooth fps and sound in Mario 64, waverace, Zelda, etc. I guess the option shouldn't be on by default for these games? ...I have to do more tests.
    Last edited by Imgema; April 2nd, 2013 at 05:30.

  2. #22
    The Great Gunblade Wielder squall_leonhart's Avatar
    Join Date
    Jan 2006
    Location
    All over the world.
    Posts
    3,514
    Mentioned
    1 Post(s)
    Quote Originally Posted by Nekokabu View Post
    Great!

    I created RDB that changed the rom name & added some roms.

    :p
    ohai Neko!

    both zilmar's and your rdbs are missing info for
    International Superstar Soccer '98 (I.S.S.98)
    Ms. Pac-Man Maze Madness (MS. PAC-MAN MM)
    Battlezone - Rise of the Black Dogs (BATTLEZONE)
    Knockout Kings 2000 (Knockout Kings 2000)
    Rat Attack (RAT ATTACK)

    Kirby64 plugin notes can be removed and marked as Compatible
    Banjo Tooie and Kazooie plugin notes should be removable.... Jabo's 1.7 plugin supports the Jiggies just fine without Framebuffer to Rdram)
    Body Harvest can be marked as Broken:Core issues.
    Gauntlet Legends needs ABL(Advanced Block Linking) disabled
    Last edited by squall_leonhart; April 2nd, 2013 at 17:27.

  3. #23
    Moderator death--droid's Avatar
    Join Date
    Feb 2008
    Posts
    1,329
    Mentioned
    10 Post(s)
    EDIT: It seems that disabling "fixed audio timing" without disabling audio sync fixes the problem with those games. I can have smooth fps and sound in Mario 64, waverace, Zelda, etc. I guess the option shouldn't be on by default for these games? ...I have to do more tests.
    Fixed audio timing is a fix to a problem in the original PJ64 where results could be completely erratic since audio interrupts were not linked to length of time. So it would never give the exact same results every time you played (terrible for netplay). Disabling both fixed audio timing and sync to audio would restore around about the pj64 1.6 behavior -- Reworded version of zilmars explanation.

    Im not actually experiencing any of these slowdowns people are talking about, chances are theres something wrong with your settings cause the slowdowns.
    If you appreciate any of my work, please consider donating
    Donate via paypal

  4. #24
    Retro Hoarder Imgema's Avatar
    Join Date
    Aug 2003
    Location
    Athens
    Posts
    38
    Mentioned
    0 Post(s)
    Quote Originally Posted by death--droid View Post
    Im not actually experiencing any of these slowdowns people are talking about, chances are theres something wrong with your settings cause the slowdowns.
    Its not as noticeable as usual slowdowns. I must choose another word besides slowdown maybe. Its more like "erratic motion". Again, its not that terrible but for some people it may be annoying.

    In the advanced settings check "frame rate display" and choose "percent of speed". Load Super Mario 64. If both "fixed audio timing" and "sync using audio" are checked (that was the default setting) you will see that the percentage isn't stable 100% but it hovers at 94-97% with some jumps to 100-103% (CPU usage is still low). If you can see this then your game doesn't run smooth. If you want to notice the difference, uncheck "fixed audio timing" and try again. You will see that percentage is stable 100% and the game runs a bit smoother now, even though it seemed fine before. Thankfully these Nintendo games won't cause audio pops with audio timing unchecked. But for plenty of other games you will have to choose between 100% smooth frame rate or pop-less sound.

    I guess this is not a major issue, this was always a thing for all N64 emulators (Mupen seems to be a little better in this). I just hoped that it was finally fixed.
    Last edited by Imgema; April 2nd, 2013 at 13:10.

  5. #25
    EmuTalk Member
    Join Date
    Apr 2013
    Posts
    2
    Mentioned
    0 Post(s)
    It is the real project64 2.0 only left the 2.0 plugins, but this don't is a problem, Zilmar make a great work since 1.7 beta, he fixed many bugs.

    Thanks Zilmar for realese this version

  6. #26
    EmuTalk Member
    Join Date
    Jun 2010
    Location
    Australia
    Posts
    48
    Mentioned
    0 Post(s)
    Quote Originally Posted by death--droid View Post
    Disabling both fixed audio timing and sync to audio would restore around about the pj64 1.6 behavior -- Reworded version of zilmars explanation.
    This.
    Website: http://dsxcorner.com
    Speedruns / HD N64 Videos: http://youtube.com/user/DsxChallenger

    Intel Core i5 3570 / Windows 7

  7. #27
    The Great Gunblade Wielder squall_leonhart's Avatar
    Join Date
    Jan 2006
    Location
    All over the world.
    Posts
    3,514
    Mentioned
    1 Post(s)
    deathdroid

    it looks like restartless plugin changes is broken in 2.x

    if only jabo had the motivation to come back and work on the d3d plugin, theres so many unfixed bugs in 1.7.0.55+ (57 broke JFG wide screen)
    Last edited by squall_leonhart; April 2nd, 2013 at 17:44.

  8. #28
    EmuTalk Member
    Join Date
    Mar 2012
    Posts
    998
    Mentioned
    5 Post(s)
    This version breaks Pilotwings 64, after failing a test and choosing "Retry", see attached image (music keeps playing).

    Tried messing with some settings, still the same. Either something is misconfigured or there was a regression in the core.
    Attached Images Attached Images  

  9. #29
    The Great Gunblade Wielder squall_leonhart's Avatar
    Join Date
    Jan 2006
    Location
    All over the world.
    Posts
    3,514
    Mentioned
    1 Post(s)
    the version of jabo included has a tonne of regressions.

    1.6.1 has some of the same bugs as 1.7.0.57v5.....

  10. #30
    EmuTalk Member
    Join Date
    Mar 2012
    Posts
    998
    Mentioned
    5 Post(s)
    Quote Originally Posted by squall_leonhart View Post
    the version of jabo included has a tonne of regressions.

    1.6.1 has some of the same bugs as 1.7.0.57v5.....
    I forgot to say the game hangs. Also happens with Rice Video and Glide64.

Page 3 of 5 FirstFirst 12345 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •