Page 3 of 51 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 504
  1. #21
    Just Another Wacko ;) PsyMan's Avatar
    Join Date
    Nov 2003
    Location
    In a weird room :\
    Posts
    2,150
    Mentioned
    0 Post(s)
    OK, here is the log using the z64 RSP:

    Code:
    rglInit()
    rglClose()
    demarrage r4300
    dynamic recompiler
    
    ABI set to ABI 1
    And here is the log using the modified PJ64 RSP:

    Code:
    rglInit()
    rglClose()
    demarrage r4300
    dynamic recompiler
    PC=80246ddc:0
    reg[ 0]:       0       0        reg[16]:       0       0
    reg[ 1]:       0       0        reg[17]:       0       0
    reg[ 2]:       0       0        reg[18]:       0       0
    reg[ 3]:       0       0        reg[19]:       0       0
    reg[ 4]:       0       1        reg[20]:       0       0
    reg[ 5]:ffffffff80364c60        reg[21]:       0       0
    reg[ 6]:ffffffff803230f4        reg[22]:       0       0
    reg[ 7]:       0       0        reg[23]:       0       0
    reg[ 8]:       0    ff01        reg[24]:ffffffff8033a730
    reg[ 9]:ffffffff80364c60        reg[25]:ffffffff8033a730
    reg[10]:       0      fe        reg[26]:ffffffffa430000c
    reg[11]:ffffffff80364c60        reg[27]:       0     aaa
    reg[12]:ffffffffa4400000        reg[28]:       0       0
    reg[13]:ffffffffa4400000        reg[29]:ffffffff80200dc8
    reg[14]:ffffffffffffffff        reg[30]:       0       0
    reg[15]:       0      fe        reg[31]:ffffffff80246dd8
    hi:       0       0        lo:       0       0
    aprθs 84401108 instructions soit 507dbd4
    Freeing 4194304 bytes at e8d0000
    Freeing 1048576 bytes at ef60000
    Freeing 2097152 bytes at ecd0000
    rglClose()
    I had to use Mupen to get logging working since PJ64 crashes on exit and the created log file is empty with it.
    Both logs were created while running Mario 64. I closed the emu 3-5 frames after the Mario 64 logo showed up.



    Edit: Forgot to mention that according to OpenGL Extensions Viewer ATi Mobility x600 supports all the needed extensions.
    Last edited by PsyMan; April 30th, 2007 at 07:29.
    I'm not insane. YOU are insane... You are all insane!


    • Advertising

      advertising
      EmuTalk.net
      has no influence
      on the ads that
      are displayed
        
       

  2. #22
    The Great Gunblade Wielder squall_leonhart's Avatar
    Join Date
    Jan 2006
    Location
    All over the world.
    Posts
    3,513
    Mentioned
    1 Post(s)
    Quote Originally Posted by sethmcdoogle View Post
    I used the lle rsp and video plugin and rogue squadron shows some stuff, battle for naboo shows the initial screen (about the expansion pack) and then dies. Also, switching between games tends to crash the emulator. Nice
    it requires advanced interpreter method to get further (naboo)

    under 1.7, it doesn't work just by setting the rom settings to interpreter, you actually have to force the emulator into Interpreter mode using the debug settings.

  3. #23
    The Great Gunblade Wielder squall_leonhart's Avatar
    Join Date
    Jan 2006
    Location
    All over the world.
    Posts
    3,513
    Mentioned
    1 Post(s)
    the modified rsp's would only crash battle for naboo in 1.7.. so i switched it to the 1.7 rsp and forced it to interpreter

    meh.. screw this... back to the *working* 1.7 plugins for me...

  4. #24
    That Damn Good
    Join Date
    Apr 2003
    Location
    Mississippi
    Posts
    1,602
    Mentioned
    0 Post(s)
    Nice to see someone working on a new gfx plugin. I'll give it a try when I have some extra time.


    Desktop: i5 3570k @ 4.5ghz, 12gb DDR 3 memory, 2x EVGA GTX670 4gb

    Laptop: Intel i7 3610QM, 12GB DDR3 memory, GTX 670m 3gb

  5. #25
    EmuTalk Member
    Join Date
    Feb 2007
    Posts
    146
    Mentioned
    0 Post(s)
    I made a new release (R3) that produce a second file called z64err.txt, possibly showing more detailed errors.

    It also fixes crash on exit in Pj64, however , you should toggle windowed mode before stopping emulation, otherwise the screen resolution won't be restored properly until you run the next ROM.

  6. #26
    Guardian ShadowFX's Avatar
    Join Date
    Dec 2001
    Location
    The Netherlands
    Posts
    276
    Mentioned
    0 Post(s)
    Are the attachements working? I can't seem to get any files.
    "Change is inevitable; progress is optional"

  7. #27
    EmuTalk Member
    Join Date
    Feb 2007
    Posts
    146
    Mentioned
    0 Post(s)
    Hmm they should, I can see them at least.

  8. #28
    Guardian ShadowFX's Avatar
    Join Date
    Dec 2001
    Location
    The Netherlands
    Posts
    276
    Mentioned
    0 Post(s)
    Alright, got it... thanks

    EDIT: I'm getting a message that SDL.dll is not founding and therefore I'm unable to load the plugin in PJ64 1.6. Any comments?
    EDIT2: it seems it is required to put SDL.dll in the core directory of the emulator. Maybe a little something to mention on the first post.
    Last edited by ShadowFX; April 30th, 2007 at 09:55.
    "Change is inevitable; progress is optional"

  9. #29
    Just Another Wacko ;) PsyMan's Avatar
    Join Date
    Nov 2003
    Location
    In a weird room :\
    Posts
    2,150
    Mentioned
    0 Post(s)
    OK... Here are the logs i get now (using PJ64 v1.6 this time).


    Using the z64 RSP:

    z64err.txt
    Code:
    viewportOffset 23
    fix hend
    creating fbo 400 320 x 240 fmt 0
    Creating depth buffer 400 1024 x 777
    creating fbo 38f800 320 x 240 fmt 0
    creating fbo 3b5000 320 x 240 fmt 0
    fix hend
    creating fbo 3da800 320 x 240 fmt 0
    fix hend
    z64log.txt
    Code:
    rglInit()
    rglClose()
    
    ABI set to ABI 1
    
    ABI set to AutoDetect
    cache hit 146978 miss 1148 0.781069%
    
    ABI set to AutoDetect

    Using the PJ64 RSP

    z64err.txt
    Code:
    viewportOffset 23
    fix hend
    creating fbo 400 320 x 240 fmt 0
    Creating depth buffer 400 1024 x 777
    creating fbo 38f800 320 x 240 fmt 0
    creating fbo 3b5000 320 x 240 fmt 0
    fix hend
    creating fbo 3da800 320 x 240 fmt 0
    fix hend
    z64log.txt
    Code:
    rglInit()
    rglClose()
    
    ABI set to ABI 1
    
    ABI set to AutoDetect
    Freeing 4194304 bytes at 1fd0000
    Freeing 1048576 bytes at 23d6000
    Freeing 2097152 bytes at 27b0000
    
    ABI set to AutoDetect
    Last edited by PsyMan; April 30th, 2007 at 09:45.
    I'm not insane. YOU are insane... You are all insane!

  10. #30
    EmuTalk Member
    Join Date
    Feb 2007
    Posts
    146
    Mentioned
    0 Post(s)
    Quote Originally Posted by EMu-LoRd View Post
    Alright, got it... thanks

    EDIT: I'm getting a message that SDL.dll is not founding and therefore I'm unable to load the plugin in PJ64 1.6. Any comments?
    EDIT2: it seems it is required to put SDL.dll in the core directory of the emulator. Maybe a little something to mention on the first post.
    Oops you're right, I forgot SDL is now used. I'll get rid of this dependency instead. (EDIT done in R4 on original post)

    PsyMan, thanks for the log. So there's not much useful yet . I'll make another release with hopefully more informations in the log.
    Last edited by ziggy; April 30th, 2007 at 10:07.

Page 3 of 51 FirstFirst 1234513 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •