PDA

View Full Version : Comments on Jnes



xamenus
December 18th, 2003, 21:40
I've recently upgraded to a new computer (specs below) and have noticed something about Jnes. The graphics are not quite as smooth as they use to be on my old Pentium 2. It's as if vsync has been disabled. I've wondered if my LCD monitor is a cause of this, but I'm not sure. This is a fairly minor problem, but smooth graphics are what I liked about Jnes. Other than that Jnes is a great emu, keep up the good work! Any comments would be appreciated. :)

P.S. On the title screen of SMB3, the ground shakes, also minor.

Clements
December 18th, 2003, 22:20
Smooth as silk here @ 1280x1024x32 with Super 2XSAI!

OK, it's blasphemous I know, but that's the way, aha aha, I like it, aha aha!

Could be the Intel graphics, but JNes is still a NES emu so I couldn't say that would be a problem, but that's the only thing I could see causing it. Unless you haven't enabled Triple Buffering. If you haven't, do it now!

xamenus
December 19th, 2003, 05:04
Smooth as silk here @ 1280x1024x32 with Super 2XSAI!

OK, it's blasphemous I know, but that's the way, aha aha, I like it, aha aha!

Could be the Intel graphics, but JNes is still a NES emu so I couldn't say that would be a problem, but that's the only thing I could see causing it. Unless you haven't enabled Triple Buffering. If you haven't, do it now!

I usually don't play ROMs in fullscreen, but I tried triple buffering but it's still not quite the same, just a very small frameskip. In windowed mode on my old computer I couldn't see any frameskip at all, it looked perfect! Maybe I'm just too particular, but the perfectly smooth graphics make it cool. ;) Thanks for your reply.

pandamoan
December 19th, 2003, 09:24
I usually don't play ROMs in fullscreen, but I tried triple buffering but it's still not quite the same, just a very small frameskip. In windowed mode on my old computer I couldn't see any frameskip at all, it looked perfect! Maybe I'm just too particular, but the perfectly smooth graphics make it cool. ;) Thanks for your reply.

not sure how much jnes relies on the gfx card, but it runs VERY smooth on my setup.

i like 2xsai as well....

Jabo
December 19th, 2003, 15:54
Just so I know the problem is, in windowed mode it runs at 60 fps but it seems like it's skipping frames ? it's not smooth ? not sure I follow

Something to consider is the Pentium 2 is just above the minimum requirement (assuming you had something <= 300 mhz) so what might of happened in windowed it is was just about rendering 60 fps .. which provided you with some form of a vsync .. now on your Pentium 4 it is so fast that it is rendering at different points in vertical blank period

scotty
December 19th, 2003, 17:44
not sure how much jnes relies on the gfx card, but it runs VERY smooth on my setup.

i like 2xsai as well....

This is the only emulator that actually runs 2xsai perfectly stable on my computer

xamenus
December 19th, 2003, 18:56
Just so I know the problem is, in windowed mode it runs at 60 fps but it seems like it's skipping frames ? it's not smooth ? not sure I follow

Something to consider is the Pentium 2 is just above the minimum requirement (assuming you had something <= 300 mhz) so what might of happened in windowed it is was just about rendering 60 fps .. which provided you with some form of a vsync .. now on your Pentium 4 it is so fast that it is rendering at different points in vertical blank period

Yeah, it runs at exactly 60 fps in windowed mode, but it looks like the graphics have lost their vsync or something. On Mario 3 and I can see the problem fairly well. Again, this may be a tad minor, but the difference is noticable anyway. My Intel graphics card could be one problem, but I don't know about the vsync bit...

Jabo
December 19th, 2003, 19:42
windowed mode does not support Vsync just in case it's not something I've advertised...

only fullscreen does that in jnes

xamenus
December 19th, 2003, 21:36
windowed mode does not support Vsync just in case it's not something I've advertised...

only fullscreen does that in jnes

I guess that explains it then, my CPU must be too fast :satisfied Thanks.

Modem
December 22nd, 2003, 20:49
Too fast? I run it just fine. And these "smooth graphics" make it sound like you just had super2x sal enabled on your older computer.

xamenus
December 22nd, 2003, 23:05
Too fast? I run it just fine. And these "smooth graphics" make it sound like you just had super2x sal enabled on your older computer.

No, I don't believe it was enabled, and I play in windowed mode, not fullscreen. And I can't find super2x sai for windowed mode (maybe it's my color settings). I keep thinking it's my monitor, it's one of those Dell flatscreen monitors. And not that I'm asking for it, but maybe Jabo wouldn't mind adding vsync support to windowed mode? :)

Jabo
December 23rd, 2003, 15:54
I can put that in the pool of longer term things, it requires direct-x-7, and traditionally it takes a while for me to progress in dx versions :P (0.5.x just was upgraded from dx3 to dx6 heh)

xamenus
December 23rd, 2003, 17:01
I can put that in the pool of longer term things, it requires direct-x-7, and traditionally it takes a while for me to progress in dx versions :P (0.5.x just was upgraded from dx3 to dx6 heh)

That's cool, I can wait, I'm in no big hurry. :)

xamenus
December 24th, 2003, 03:14
Well, it looks like I solved the problem! I just changed my monitor refresh rate from 75 hz to 60 hz, and now the graphics are smooth. However, the lack of vsync still makes the graphics imperfect in windowed mode, that's the only problem now. So I'm looking forward to vsync support! :D