PDA

View Full Version : Rice's Daedalus 4.1.0 beta1 feedback thread



Rice
February 13th, 2003, 01:35
Post your response here, and describe your problems and your computer/video card config.

I have posted a binary file built for DirectX 8.0a for someone does not have DirectX 8.1 installed, see it at:

File for DirectX 8.0a (http://www.emutalk.net/showthread.php?s=&postid=119705#post119705)

Rice

LazerTag
February 13th, 2003, 05:15
If depth buffer / zbuffer does not work, you will see objects will overlapping each other

This doesn't happen in all games, but I have noted it in Mario Golf when I am set for Nvidia OGL. I'm using a GF4 ti4200 with Det.v.41.09 and DirectX 9.0 on Win XP Pro.

Would this be normal for that game?

I have all kinds of odd looking texture issues (mostly flickering or like the texture is covering something up) in most games whether or not I am set for OGL or D3D.

Lillymon
February 13th, 2003, 07:12
I've got all sorts of problems. When testing Mario 64, the DirectX renderer pretty much went nuts and put polygons anywhere. It could be a problem with the Z-buffer.

Unusually (for my ATI Radeon 8500) the OpenGL renderer is better, but it's still only borderline playable.

Maybe I'm asking for it with DirectX 9.0, I'll try installing the latest drivers and retesting.

euphoria
February 13th, 2003, 13:54
DirectX mode gives D3DERR_INVALIDCALL Error MsgBox and freezes 1964 0.8.5 :( It seems as there is something going wrong in initialization since the MsgBox pops up right after the ROM is loaded.

Windows 2000
DirectX 8.0
Matrox G450

To sum it up, there's no improvement on my setup compared to previous release, but hopefully these errors get corrected sometime :daedalus:

Project64 1.5 crashes with memory read error from address 0x00000000

Rice
February 13th, 2003, 15:31
Originally posted by euphoria
DirectX mode gives D3DERR_INVALIDCALL Error MsgBox and freezes 1964 0.8.5 :( It seems as there is something going wrong in initialization since the MsgBox pops up right after the ROM is loaded.

Windows 2000
DirectX 8.0
Matrox G450

To sum it up, there's no improvement on my setup compared to previous release, but hopefully these errors get corrected sometime :daedalus:

Project64 1.5 crashes with memory read error from address 0x00000000


I think I have found this problem because one global variable is not initialized. The problem happens only to the lower end video card combiner. You have got G450, why not you try to manual select the high end combiner?

Rice
February 13th, 2003, 16:04
The file has been updated in the original thread. If you have the problem of emulator crashing, you can try to download the file again and give it a try.

euphoria
February 13th, 2003, 16:16
Same thing happens: D3DERR_INVALIDCALL with "To Fit.." and manually "High End..." and it freezes after. Maybe you could release a debug version that dumps initialization info to file and see what it fails on. I'll have to go now but i could test it tomorrow.

Rice
February 13th, 2003, 17:15
Originally posted by euphoria
Same thing happens: D3DERR_INVALIDCALL with "To Fit.." and manually "High End..." and it freezes after. Maybe you could release a debug version that dumps initialization info to file and see what it fails on. I'll have to go now but i could test it tomorrow.

Can you update your DirectX to 8.1, the plugin requires DX 8.1.

Raziel64
February 13th, 2003, 23:30
There`s some way to fix it?

jacky400
February 14th, 2003, 04:03
Test game:Mario 64
CPU:P4 1.8A
RAM:256 DDR
OS: WINXP with DX8.1
Render Type selected in Plugin : DirectX 8.0/8.1

1.Low end combiner (Intel 845G onboard graphic chipset)

Problem : Mario head in whole black color after the title screen while background is ok ,ingame haven't test.


2.High end combiner (Geforce 2 MX440)

No problems found in title and ingame.

Raziel64
February 14th, 2003, 04:26
Can somebody can make it work with Dx9?

Rice
February 14th, 2003, 05:03
Just installed DirectX9 and tested, the plugin works fine for me without rebuild. I don't have much to say, you can try to update your device driver.


My config.

PIII-600M, 256+128+64 MB
Geforce 2 MX/MX 400 32MB
Driver: Nvidia 4.1.0.9, 11/18/2002


Rice

Raziel64
February 14th, 2003, 05:20
Thanks!.

euphoria
February 14th, 2003, 10:08
Originally posted by Rice
Can you update your DirectX to 8.1, the plugin requires DX 8.1.
Just a thought but why the hell does it say DirectX 8.0/8.1 then? :angry: But to get serious, should i download DX9 instead since my 56k modem connection & my wallet doesn't allow many downloads?

Doomulation
February 14th, 2003, 12:32
Just buy a game magazine :baaa:
It will probably contain dx 8.1 or 9 on a cd.
Btw rice, you should post your plugin progress in one thread to avoid this situation ;)

Nice work, btw.

Lillymon
February 14th, 2003, 15:43
I've updated my ATI Radeon 8500's drivers and still have the wacky Z-buffer problem with Direct3D. OpenGL 1.2 works best but still with some glitches.

jvolel
February 14th, 2003, 15:51
rice can you add a model extractor.. or vert extracxting/logging option please please please!!!! :flowers:

Rice
February 14th, 2003, 18:45
Originally posted by euphoria
Just a thought but why the hell does it say DirectX 8.0/8.1 then? :angry: But to get serious, should i download DX9 instead since my 56k modem connection & my wallet doesn't allow many downloads?

Could be my fault. I thought DirectX 8.0 and 8.1 are binary interchangable as they are using the same interface. Ya, you can download DirectX 9, at the meantime, I will try to build it again with DirectX 8.0a library so someone like you can try it.


Rice

Rice
February 14th, 2003, 18:46
Originally posted by jvolel
rice can you add a model extractor.. or vert extracxting/logging option please please please!!!! :flowers:

You can build a DEBUG version by using the source code, it has vtx logging features.

Rice
February 14th, 2003, 20:31
This build is linked with DirectX 8.0a library, it is not a replacement, but just for whoever does not have DirectX 8.1 installed.

jvolel
February 14th, 2003, 21:15
Where can I get thw source code?... uh how would I build a debugger? :blush: :doh:

Raziel64
February 15th, 2003, 13:32
Can you rebuild it for dx7?... I`m a banshee user and with this card the plugin only shows strange colors and very, very poor graphics.

Rice
February 15th, 2003, 19:11
Originally posted by jvolel
Where can I get thw source code?... uh how would I build a debugger? :blush: :doh:

Look at .this thread (http://www.emutalk.net/showthread.php?s=&threadid=11166) for source code

Rice
February 15th, 2003, 19:12
Originally posted by Raziel64
Can you rebuild it for dx7?... I`m a banshee user and with this card the plugin only shows strange colors and very, very poor graphics.


No, I can not.

DirectX7 is quite different from DirectX8, function calls are all different. It is a big job to port it back to DirectX7.

I believe Banshee only support 16bit buffer, and this plugin does not support 16bit very well.

Raziel64
February 15th, 2003, 19:26
Can you fix that?

Rice
February 15th, 2003, 20:13
Not at this moment, it is a big deal, not a small fix.

Doomulation
February 15th, 2003, 20:15
Why don't you just buy a game magazine so you have directx8? Not a hard deal, is it? You'll probably need it later, as well. Save poor rice from porting it :(
He can spend that time on doing better things instead :)

Raziel64
February 15th, 2003, 20:20
:)
In fact, I have Dx9 final installed, but this donŽt fix my problem. Anyway, if Rice can fix this later (not only for me, mostly low-end-vid-card users will apreciate it), IŽll just wait.

Rice: youŽre right, Banshee only supports 16 bit buffer.:(

ScottJC
February 16th, 2003, 13:45
As I was saying in that other thread, testing one game at a time:

Mario Kart

Not a serious glitch but it is quite noticeable, lines throughout the sprites used in the menus, there are bigger problems though, as i will get on to...

ScottJC
February 16th, 2003, 13:47
glitch 2, Black Sprites in-game, Erk! serious problem here :)

ScottJC
February 16th, 2003, 13:49
another big problem, the track's textures like to change sometimes;

ScottJC
February 16th, 2003, 13:52
just for complete bug report:

I use DirectX 9 Final
Detonator Driver Version 4.1.0.9 (for Geforce 4)
Windows XP
Running on 16bit color

Specs in my Sig

and here are my settings for the plugin:

Raziel64
February 16th, 2003, 19:19
All games in OpenGL 1.1...

Raziel64
February 16th, 2003, 19:22
Banshee DX problem... (Banjo-Kazooie)

euphoria
February 17th, 2003, 15:08
Originally posted by Rice
This build is linked with DirectX 8.0a library, it is not a replacement, but just for whoever does not have DirectX 8.1 installed.
It still gives the same D3DERR_INVALIDCALL MessageBox... and then "Unknown Error in Daedalus D3D plugin ProcessDList" and freezes.